CCS C Software and Maintenance Offers
FAQFAQ   FAQForum Help   FAQOfficial CCS Support   SearchSearch  RegisterRegister 

ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

CCS does not monitor this forum on a regular basis.

Please do not post bug Reports on this forum. Send them to support@ccsinfo.com

e3mini development board

 
Post new topic   Reply to topic    CCS Forum Index -> General CCS C Discussion
View previous topic :: View next topic  
Author Message
johnglen



Joined: 27 Feb 2016
Posts: 2

View user's profile Send private message

e3mini development board
PostPosted: Sat Feb 27, 2016 11:42 am     Reply with quote

Bought the Embedded C Programming book and e3mini bundle. Having a problem loading the program onto the e3mini

When I try to load the program, I get a "Timeout while downloading" - the program doesn't load to the e3mini.

I have reloaded the e3mini driver, and it shows up correctly in Device Manager. Also - after it stops downloading, then the Serial I/O Monitor shows me the test program running. The test program functions - I can press the C1 / C2 buttons and the the pot input show a response.

Any suggestions on why I can't download the s/w to the e3mini board?
johnglen



Joined: 27 Feb 2016
Posts: 2

View user's profile Send private message

e3mini development board
PostPosted: Sat Feb 27, 2016 11:46 am     Reply with quote

Further to my last - the book (Exercise 1-1, Step 6) indicates that I should select "PROGRAM CHIP" and then "E3 BOOTLOAD"

On my version of the PICC Compiler, when I select PROGRAM on the Compile Menu at the top of the screen, I don't get "E3 BOOTLOAD". I see:

"E3 USB Loader"
"ICD"
"Bootloader"
"RapidUSB Loader"
temtronic



Joined: 01 Jul 2010
Posts: 5741
Location: Greensville,Ontario

View user's profile Send private message

PostPosted: Sat Feb 27, 2016 1:07 pm     Reply with quote

hmm I'd be asking CCS directly, though you might try searching for 'e3mini' here.
From a quick look at their ad it appears that it has a bootloader already installed so I assume you download YOUR program via the USB port.
With that I'd try the 'e3 usb loader'. Hopefully there's better descriptions as to what is what, what does what, etc. if not, as I already said, contact CCS ask for help.

edit:

maybe look here ??
http://www.ccsinfo.com/e3mini-board.php

watch/listen to the videos ??



Jay
wiztizGT



Joined: 10 Nov 2016
Posts: 6
Location: West Chester, PA

View user's profile Send private message

PostPosted: Thu Nov 10, 2016 8:08 am     Reply with quote

I am having the same issue. Were you able to resolve the problem?
CCS



Joined: 31 Oct 2005
Posts: 7

View user's profile Send private message Send e-mail

Windows 10 USB 3.0 Bug
PostPosted: Thu Nov 10, 2016 1:47 pm     Reply with quote

There is a bug in the newest Microsoft USB drivers. When Windows upgrades the OS it installs their drivers by default. Go to the website of the USB device manufacturer and download and install their driver. For example
a lot of people with this problem have Intel chips. The Intel web site has a utility that will update all your drivers with Intel versions.

An alternative for some people is to go into BIOS and disable XHCI for the USB 3.0 ports. Not all BIOS versions have this option. This is only a problem on USB 3.0 ports using the generic Microsoft driver.

This problem only affects CDC devices so other devices will seem to work on the USB 3.0 port with the bad driver.
_________________
Custom Computer Services, Inc.
262-522-6500
PO Box 2452
Brookfield, WI 53008
wiztizGT



Joined: 10 Nov 2016
Posts: 6
Location: West Chester, PA

View user's profile Send private message

PostPosted: Sat Nov 12, 2016 9:43 am     Reply with quote

Thanks! I have an Asus motherboard with ASmedia USB ports with ASmedia drivers. It seems to work fine in those USB ports.
wiztizGT



Joined: 10 Nov 2016
Posts: 6
Location: West Chester, PA

View user's profile Send private message

PostPosted: Sat Nov 12, 2016 7:05 pm     Reply with quote

So it seemed to work well on an ASmedia port for a while then the serial port communication started getting flaky and then it started throwing errors on download. I disabled XHCI in the BIOS and now it seems to be working well on all ports. I will post again if it starts acting up.
wiztizGT



Joined: 10 Nov 2016
Posts: 6
Location: West Chester, PA

View user's profile Send private message

e3mini died???
PostPosted: Sat Nov 19, 2016 8:55 pm     Reply with quote

Everything seemed to be fine until earlier today. I was loading the program and nothing came out on the serial port. Next thing I know I have the Blue Screen of death and it appears as if my entire USB controller died. I got everything running again except for the E3. The computer does nothing when I plug it in, and the compiler won't recognize it.

Any ideas on how to recover the e3?
PCM programmer



Joined: 06 Sep 2003
Posts: 20098

View user's profile Send private message

PostPosted: Sun Nov 20, 2016 12:03 am     Reply with quote

See this thread and the links in it. I don't know if this will help but it might:
http://www.ccsinfo.com/forum/viewtopic.php?t=53371
wiztizGT



Joined: 10 Nov 2016
Posts: 6
Location: West Chester, PA

View user's profile Send private message

PostPosted: Sun Nov 20, 2016 8:46 am     Reply with quote

Thanks for the suggestion PCM programmer.

I actually went through that post while I was trying to get everything working again.

I have a hunch the board might be shot. I will take it to work tomorrow and probe the voltages.
wiztizGT



Joined: 10 Nov 2016
Posts: 6
Location: West Chester, PA

View user's profile Send private message

Fix
PostPosted: Tue Nov 29, 2016 7:09 pm     Reply with quote

I contacted tech support. They suggested that I hold both buttons down when I plugged the board into the computer.

It worked! I was able to load a program and it seems to be running normally again.
j_andrew



Joined: 25 Dec 2016
Posts: 1

View user's profile Send private message

Re: e3mini development board
PostPosted: Sun Dec 25, 2016 9:44 pm     Reply with quote

Did you ever get an answer to your problem? I too just bought the book and the e3mini board and am getting the timeout error msg and production test sequence output on the monitor.
jurie



Joined: 25 Aug 2017
Posts: 1

View user's profile Send private message Send e-mail

e3 time out errors problems
PostPosted: Tue Sep 05, 2017 12:02 pm     Reply with quote

I too just bought the book and the e3mini board and am getting the timeout error msg and production test sequence output on the monitor.
Yellow led is blinking.
c1 and c2 holding when connecting usb.
Yellow led blinking by progaming timeerror.

My pc is a apple with vmware windows 10.
Mplab, icd3, icd64, 18f45k22 board works great on windows 10.

Hardware Overview:

Modelnaam: MacBook Pro
Modelaanduiding: MacBookPro13,3
Processornaam: Intel Core i7
Processorsnelheid: 2,7 GHz
Aantal processors: 1
Totale aantal cores: 4
L2-cache (per core): 256 KB
L3-cache: 8 MB
Geheugen: 16 GB
Opstart-ROM-versie: MBP133.0226.B25
SMC-versie (systeem): 2.38f7
Serienummer (systeem): C02T5036GTFM
Hardware-UUID: 5A8F99EB-5435-5ACD-BE79-30ABF3BD10CB

USB 3.0-bus: usb-c to usb

Besturingsbestand hostcontroller: AppleUSBXHCISPT
PCI-apparaatcode: 0xa12f
PCI-revisiecode: 0x0031
PCI-fabrikantcode: 0x8086

iBridge:

Productcode: 0x8600
Fabrikantcode: 0x05ac (Apple Inc.)
Versie: 1.01
Snelheid: Maximaal 480 Mb/sec
Fabrikant: Apple Inc.
Locatiecode: 0x14200000 / 40
Beschikbare stroom (mA): 500
Vereiste stroom (mA): 0
Extra stroom in werking (mA): 0
Ingebouwd: Ja
bdeb



Joined: 05 Nov 2010
Posts: 10
Location: Sweden

View user's profile Send private message Visit poster's website

Work-around
PostPosted: Sun Nov 26, 2017 11:18 am     Reply with quote

I'm having the same problems.

Since I have loads of test- and production thingies connected via USB, I simply do not dare to tinker with the root drivers in my computers.

Tried connecting E3mini via old (non-USB3) hub - works like a charm!


Hope this helps:


/Björn
Display posts from previous:   
Post new topic   Reply to topic    CCS Forum Index -> General CCS C Discussion All times are GMT - 6 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group