CCS C Software and Maintenance Offers
FAQFAQ   FAQForum Help   FAQOfficial CCS Support   SearchSearch  RegisterRegister 

ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

CCS does not monitor this forum on a regular basis.

Please do not post bug Reports on this forum. Send them to support@ccsinfo.com

CSS ICD-S40 issue: upgrading firmware/programming pic16f88

 
Post new topic   Reply to topic    CCS Forum Index -> CCS ICD / Mach X / Load-n-Go
View previous topic :: View next topic  
Author Message
marcidy



Joined: 24 Nov 2004
Posts: 2

View user's profile Send private message Send e-mail Visit poster's website AIM Address

CSS ICD-S40 issue: upgrading firmware/programming pic16f88
PostPosted: Wed Nov 24, 2004 10:46 pm     Reply with quote

The ICD control software detects my chip(PIC16F88). When I try and update the firmware, it gets to 100% then the following error occurs:
Cannot start firmware: Did not ack message B0"

I'm attempting to upgrade FROM fw version v1.28 TO v1.29.

I just received the ICD today and have never used it to program the chip. The ICD and target pass the tests. When the comm test is run, the response code comes back invalid, if it comes back at all. Sometimes no ack is received. Everything else on the comm test comes back ok.

Using the advanced options, I can read/write portions of the chip. When I attempt to program the chip, I get this lovely and unhelpful error.

access violation at address 00b26002 in module 'ccsicd.dll'. Write of address 0000000.

Please please please let me know what's going on. This project is taking too long for the wrong reasons (as they always do).

-Matt
Haplo



Joined: 06 Sep 2003
Posts: 659
Location: Sydney, Australia

View user's profile Send private message

PostPosted: Wed Nov 24, 2004 11:02 pm     Reply with quote

You are getting an access violation in CCSICD.DLL...You should contact CCS tech support about this. They are usually very helpful. Remember this forum is not the official tech support.
marcidy



Joined: 24 Nov 2004
Posts: 2

View user's profile Send private message Send e-mail Visit poster's website AIM Address

reCSS ICD-S40 issue: upgrading firmware/programming pic16f88
PostPosted: Wed Nov 24, 2004 11:08 pm     Reply with quote

Thanks for the quick reply. As always, it was something stupid. It's some combination of:

1) setting the baud on the serial port to match the ICD(or vice versa)((duh)).
2) getting the latest ICD software
3) updating the firmware to 1.30.
4) Rebooting.

The newer version suggests a reboot, while the one that come on the CD did not, so that was most likely the issue.

Thanks!
Display posts from previous:   
Post new topic   Reply to topic    CCS Forum Index -> CCS ICD / Mach X / Load-n-Go All times are GMT - 6 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group