CCS C Software and Maintenance Offers
FAQFAQ   FAQForum Help   FAQOfficial CCS Support   SearchSearch  RegisterRegister 

ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

CCS does not monitor this forum on a regular basis.

Please do not post bug Reports on this forum. Send them to support@ccsinfo.com

Using the ICD to program without DEBUG enabled

 
Post new topic   Reply to topic    CCS Forum Index -> CCS ICD / Mach X / Load-n-Go
View previous topic :: View next topic  
Author Message
splevy
Guest







Using the ICD to program without DEBUG enabled
PostPosted: Sun Oct 10, 2004 10:46 am     Reply with quote

The old Microchip ICD would allow you to turn off the debug function and program code for stand-alone operation. Is that also true for the ICD-S40?

My program is running fine with the ICD attached. Removing the DEBUG line and recompiling is successful, but when I try to enable the ICD to program the chip with what should be non-debug code, it offers to recompile with the debug option. If I decline, I can't use the ICD.

I must be missing something obvious, but any help would be appreciated.

Thanks.

Stan
Haplo



Joined: 06 Sep 2003
Posts: 659
Location: Sydney, Australia

View user's profile Send private message

PostPosted: Sun Oct 10, 2004 4:56 pm     Reply with quote

It seems you are using the PCW debugger to program your chip. Use ICD.EXE instead, this should solve your problem.
splevy
Guest







PostPosted: Sun Oct 10, 2004 9:29 pm     Reply with quote

Thanks. That solved my problem.

I appreciate the help.

Stan
Smile
Display posts from previous:   
Post new topic   Reply to topic    CCS Forum Index -> CCS ICD / Mach X / Load-n-Go All times are GMT - 6 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group