CCS C Software and Maintenance Offers
FAQFAQ   FAQForum Help   FAQOfficial CCS Support   SearchSearch  RegisterRegister 

ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

CCS does not monitor this forum on a regular basis.

Please do not post bug Reports on this forum. Send them to support@ccsinfo.com

PIC18F452 doesn't start

 
Post new topic   Reply to topic    CCS Forum Index -> General CCS C Discussion
View previous topic :: View next topic  
Author Message
Zwizzle
Guest







PIC18F452 doesn't start
PostPosted: Fri Mar 21, 2003 1:01 pm     Reply with quote

Hi all,

I have recently migrated a project from the 16f877 to the 18f452, due to lack of space. I use MPLab 6.13, and the ICD2 programmer. Problem that occured is this: the PIC won't start. If I load it without debug mode, it doesn't do anything. If I use it *with* debug mode, it still doesn't do anything, although I can force it by 'stepping into' the code. If I do this, the ICD2 seems to reset several times before it takes the next step. In other words: it's useless. I've been fiddeling with the config bits, but no such luck so far. Does anyone recognize this?

Thanks!
___________________________
This message was ported from CCS's old forum
Original Post ID: 12930
Neutone



Joined: 08 Sep 2003
Posts: 839
Location: Houston

View user's profile Send private message

Re: PIC18F452 doesn't start
PostPosted: Fri Mar 21, 2003 2:54 pm     Reply with quote

:=Hi all,
:=
:=I have recently migrated a project from the 16f877 to the 18f452, due to lack of space. I use MPLab 6.13, and the ICD2 programmer. Problem that occured is this: the PIC won't start. If I load it without debug mode, it doesn't do anything. If I use it *with* debug mode, it still doesn't do anything, although I can force it by 'stepping into' the code. If I do this, the ICD2 seems to reset several times before it takes the next step. In other words: it's useless. I've been fiddeling with the config bits, but no such luck so far. Does anyone recognize this?
:=
:=Thanks!

Did you unplug the ICD2 from the circuit? While it is pluged into the circuit it will hold the circuit in reset.
___________________________
This message was ported from CCS's old forum
Original Post ID: 12933
Zwizzle
Guest







Re: PIC18F452 doesn't start
PostPosted: Fri Mar 21, 2003 3:39 pm     Reply with quote

:=Did you unplug the ICD2 from the circuit? While it is pluged into the circuit it will hold the circuit in reset.

Yes I did. I also started a new project and pasted CCS's Watchdog18 example into it. It has the same problem: it compiles, but won't run, not in debug mode and not without it. HEX upload to the PIC18 is ok, ie. I can read it back without errors. I've installed the right crystal (HS), every internal 'device' (watchdog timer, powerup timer, etc) are disabled. And still the device doesn't start.
___________________________
This message was ported from CCS's old forum
Original Post ID: 12935
Display posts from previous:   
Post new topic   Reply to topic    CCS Forum Index -> General CCS C Discussion All times are GMT - 6 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group