CCS C Software and Maintenance Offers
FAQFAQ   FAQForum Help   FAQOfficial CCS Support   SearchSearch  RegisterRegister 

ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

CCS does not monitor this forum on a regular basis.

Please do not post bug Reports on this forum. Send them to support@ccsinfo.com

IDE Version 5.092 Crashes

 
Post new topic   Reply to topic    CCS Forum Index -> General CCS C Discussion
View previous topic :: View next topic  
Author Message
soonc



Joined: 03 Dec 2013
Posts: 194

View user's profile Send private message

IDE Version 5.092 Crashes
PostPosted: Wed Jan 22, 2020 7:26 pm     Reply with quote

Beware: Setting bookmark has crashed the IDE and I've lost code.

Work-Around: Do Ctrl+S before setting Bookmarks !

I have reported this.
allenhuffman



Joined: 17 Jun 2019
Posts: 389
Location: Des Moines, Iowa, USA

View user's profile Send private message Visit poster's website

PostPosted: Wed Jan 29, 2020 9:26 am     Reply with quote

Thanks for sharing this tip. I've gotten used to restarting my PC fresh every morning, and when switching projects I manually close all the windows first and then exit CCS and open the new ccspjt file manually. That seems to reduce it writing files into the new directory (usually just the old project file, but once it spewed out a bunch of source files too -- assuming they were the ones I had open).

Maybe we could start a topic for crashes and workarounds, and just keep editing the top post as folks contribute new items.
_________________
Allen C. Huffman, Sub-Etha Software (est. 1990) www.subethasoftware.com
Embedded C, Arduino, MSP430, ESP8266/32, BASIC Stamp and PIC programmer.
www.whywouldyouwanttodothat.com ?
Ttelmah



Joined: 11 Mar 2010
Posts: 15749

View user's profile Send private message

PostPosted: Wed Jan 29, 2020 2:26 pm     Reply with quote

Not been able to duplicate this. Tried doing bookmarks all over the place,
then toggling them and going to them, and no crash.
Wonder if it is possibly something to do with permissions?.
CCS has some oddities relating to the permissions in the compiler home
directory, and this may be another.
GusA



Joined: 28 Mar 2020
Posts: 3
Location: York, PA

View user's profile Send private message

PostPosted: Sat Mar 28, 2020 10:58 am     Reply with quote

I am a new CCS IDE user. I just purchased and installed version 5.093. I created a simple project, basically to navigate the IDE and learn about general usage. I had two IDE crashes. I sent the following inquiry to CCS tech support yesterday, have not received a reply yet.

****** INQURY ******
CCS IDE crash, all I did was click on Find All References. See error screens on .jpg images attached.
This happened a second time when Find All Files was attempted (CTRL F).
This is disappointing, especially if it happens between project saves.
Is this a known occurrence? If so, is there a work around?
I am running on Windows 7.
****** END OF INQUIRY ******

I cannot upload the images onto this forum, no option available to do so. Basically they display:

ERROR - Out of system resources

C Compiler IDE is not responding
-> Close program
-> Wait for program to respond

Thank you for any comments/suggestions you can provide on this matter.
temtronic



Joined: 01 Jul 2010
Posts: 7355
Location: Greensville,Ontario

View user's profile Send private message

PostPosted: Sat Mar 28, 2020 11:09 am     Reply with quote

hmm....
ERROR - Out of system resources

If this is a Windows problem....
...I'm wondering how many programs/appliations you've got running in Windows.

Being 'old' I only have 3, maybe 4 ( tbird/firefox/mplab and realterm)
GusA



Joined: 28 Mar 2020
Posts: 3
Location: York, PA

View user's profile Send private message

PostPosted: Sat Mar 28, 2020 11:21 am     Reply with quote

Only a couple other applications running. I have used MPLAB X on the same computer to develop a few projects, never have had this problem. A new customer asked me to go to CCS, so here I am.

If the license lets me, I will install CCS on my laptop running Windows 10, and test on it as well.
Thanks!
newguy



Joined: 24 Jun 2004
Posts: 1663
Location: Edmonton, Alberta

View user's profile Send private message

PostPosted: Sat Mar 28, 2020 12:33 pm     Reply with quote

There's been times when the CCS compiler starts doing strange things for me....most recently about 6 months ago. Delete the installation directory and try reinstalling it first. That might clear up your issues.
Display posts from previous:   
Post new topic   Reply to topic    CCS Forum Index -> General CCS C Discussion All times are GMT - 6 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group