CCS C Software and Maintenance Offers
FAQFAQ   FAQForum Help   FAQOfficial CCS Support   SearchSearch  RegisterRegister 

ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

CCS does not monitor this forum on a regular basis.

Please do not post bug Reports on this forum. Send them to support@ccsinfo.com

Verification Problem Please Help

 
Post new topic   Reply to topic    CCS Forum Index -> CCS ICD / Mach X / Load-n-Go
View previous topic :: View next topic  
Author Message
rlgreen



Joined: 07 Dec 2007
Posts: 8

View user's profile Send private message

Verification Problem Please Help
PostPosted: Mon Jun 02, 2008 10:26 pm     Reply with quote

I have 2 u40 programmers. I am having the following problem and it's driving me nuts. I've searched, using the search tool and have not found a solution.

I'm using a PIC16F887, CCS compiler version 4.064. I've downloaded the latest ICD-U40 firmware.

The problem I have: My program compiles fine. When I program the device, the first time, it gives me a "Verification error". RAM locations do not match "expected" values. I can usually just "Hit" program again and it will work. Some times, it can't find my device. I have to recycle power to the hardware and the unit can be programmed.

I also find that many times during the day, I have to unplug and replug in the USB cable to continue work.

I use RB3. Shouldn't I be able too? I have "fast" enabled in the ICD software.

What can I possibly do to remedy this problem. Should I just use my ICD2 programmer? Will this solve my problem? I'm wasting "Hours" a day programming PIC's twice.
Guest_7068
Guest







PostPosted: Sat Jun 07, 2008 5:46 pm     Reply with quote

That chip has an errata associated with it, which states that PIN B3 must be grounded during ICSP mode.
Keeping this pin floating will cause verification errors. This errata is valid for following devices:
16F882
16F883
16F884
16F886
16F887
scott
Guest







Verificaiton errors using 16f887
PostPosted: Sun Jun 08, 2008 6:46 pm     Reply with quote

I'm using the same PIC and getting the same Verificaiton errors. Would like to here how you overcame this problem.
Dimmu



Joined: 01 Jul 2007
Posts: 37

View user's profile Send private message

PostPosted: Mon Jun 09, 2008 4:41 am     Reply with quote

Don't know if this helps but I had a lot of problems with the ICD-U40 when it was plugged on a USB hub.
I moved it on a native USB of the computer and the errors disappeared

Dimmu
paolop
Guest







Verification errors with 16F886
PostPosted: Mon Jun 16, 2008 2:04 pm     Reply with quote

It seems that this chip can't be programmed in normal program mode.
Curiously in fast program mode it works.
The main problem is that the debugger apparently uses the normal program mode and thus it doesn't work.

Note: I'm using ICD V2.95, ICD-U40 CCS2.25 Rev#97, PCWHD 4.068

Is there any other that have experienced this issue ?
Any suggestions about how to make the debugger working ?
javi.ar



Joined: 17 Feb 2006
Posts: 59
Location: Argentina

View user's profile Send private message Send e-mail Visit poster's website MSN Messenger

16F8XX
PostPosted: Wed Oct 03, 2012 5:55 pm     Reply with quote

I have a production lot of 250 units with 16F883, I had to place a wire mannually between PIN_B3 and GND. It worked.

Next time I will prototype with the same exactly kind...
Display posts from previous:   
Post new topic   Reply to topic    CCS Forum Index -> CCS ICD / Mach X / Load-n-Go All times are GMT - 6 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group