CCS C Software and Maintenance Offers
FAQFAQ   FAQForum Help   FAQOfficial CCS Support   SearchSearch  RegisterRegister 

ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

CCS does not monitor this forum on a regular basis.

Please do not post bug Reports on this forum. Send them to support@ccsinfo.com

ICD-U40 Bricked? Not Responding?

 
Post new topic   Reply to topic    CCS Forum Index -> CCS ICD / Mach X / Load-n-Go
View previous topic :: View next topic  
Author Message
georgesmart1



Joined: 01 Dec 2012
Posts: 2
Location: London, England

View user's profile Send private message Visit poster's website

ICD-U40 Bricked? Not Responding?
PostPosted: Sat Dec 01, 2012 10:45 am     Reply with quote

Hello and thanks for your time.

I've recently got back into developing with CCS C, and dug out my old ICD-U40 in circuit debugger. After installing and configuring all of the (new shiny) software, I programmed my code and was on my way.

I noticed when using the debugger, that it kept telling me my firmware was old (Limited firmware or something?) and so I decided to program it.

From the CCSload program's help, I noticed the ccsload.exe upgrade command, and so I upgraded with icd-images-firmware-02-95.fw, the newest firmware it downloaded from the website.

I can only assume it's not for my ICD-U40 as half way through the flashing process I received an error message (and my heart sunk). The ICD-U40 now no longer responds to the ccsload program, but is found by Window's device manager. I guess the FTDI chip is still okay, but I've bricked the boot loader inside the ICD PIC. Hopefully I'm wrong.......

I have another ICD-U40 (untouched working) that I can reprogram the first (bricked) one with if needs be, but I'm really dunno what to do?

If anyone can offer any advice, I would really appreciate it? Cheers all.

George Smart, M1GEO.
http://www.george-smart.co.uk/
jeremiah



Joined: 20 Jul 2010
Posts: 994

View user's profile Send private message

PostPosted: Sun Dec 02, 2012 11:10 am     Reply with quote

The best I can recommend is talk with the CCS support about it. Over the past few years they have been very good at working with me on the ICD-U40 and making firmware updates to help continue support it. I actually haven't updated the firmware on mine for a while because it now works with all the chips I use already.
georgesmart1



Joined: 01 Dec 2012
Posts: 2
Location: London, England

View user's profile Send private message Visit poster's website

PostPosted: Sun Dec 02, 2012 6:27 pm     Reply with quote

I shall speak with them. Thanks very much.
George
Display posts from previous:   
Post new topic   Reply to topic    CCS Forum Index -> CCS ICD / Mach X / Load-n-Go All times are GMT - 6 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group