CCS C Software and Maintenance Offers
FAQFAQ   FAQForum Help   FAQOfficial CCS Support   SearchSearch  RegisterRegister 

ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

CCS does not monitor this forum on a regular basis.

Please do not post bug Reports on this forum. Send them to support@ccsinfo.com

ICD-U64 Can't Read Device ID - PGD not going low

 
Post new topic   Reply to topic    CCS Forum Index -> CCS ICD / Mach X / Load-n-Go
View previous topic :: View next topic  
Author Message
allredsd



Joined: 02 Jun 2011
Posts: 4
Location: Austin, Texas

View user's profile Send private message

ICD-U64 Can't Read Device ID - PGD not going low
PostPosted: Tue Mar 27, 2012 9:25 am     Reply with quote

I have started having trouble loading a new program on my custom board using CCSLOAD and the ICD-U64. The device ID reads all '1's.

After going through the diagnostics, I found that the PGD pin was not being pulled low (from VCC=4.98, it would only pull down to 3.7 Volts). I have previously been able to program and debug on this board before.

I moved the programmer over to my PIC18F45K22 demo board, and am having the same issue (PGD only pulls down to 3.7V).

Does this point to a faulty programmer, or could there be some other explanation for what I'm seeing?

Any help is appreciated!!

Scott
Display posts from previous:   
Post new topic   Reply to topic    CCS Forum Index -> CCS ICD / Mach X / Load-n-Go All times are GMT - 6 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group