CCS C Software and Maintenance Offers
FAQFAQ   FAQForum Help   FAQOfficial CCS Support   SearchSearch  RegisterRegister 

ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

CCS does not monitor this forum on a regular basis.

Please do not post bug Reports on this forum. Send them to support@ccsinfo.com

Mystery PCW error when compiling

 
Post new topic   Reply to topic    CCS Forum Index -> General CCS C Discussion
View previous topic :: View next topic  
Author Message
rabarton
Guest







Mystery PCW error when compiling
PostPosted: Fri Mar 21, 2003 6:52 pm     Reply with quote

When I compile the code, a CCS C error window pops up and says:
"Invalid line or paragraph index."
By repeating this and trying to capture the screen right before the error occurs, I can tell that the error happens after the "Linking" line comes up, and after it says "Writing project.COD".
I've changed very little since my last succesful compile. I'll go back and grab some old revisions of code to try them again. In the meantime, any suggestions?
___________________________
This message was ported from CCS's old forum
Original Post ID: 12940
PCM programmer



Joined: 06 Sep 2003
Posts: 20335

View user's profile Send private message

Re: Mystery PCW error when compiling
PostPosted: Fri Mar 21, 2003 7:59 pm     Reply with quote

:=When I compile the code, a CCS C error window pops up and says:
:="Invalid line or paragraph index."
:=By repeating this and trying to capture the screen right before the error occurs, I can tell that the error happens after the "Linking" line comes up, and after it says "Writing project.COD".
:=I've changed very little since my last succesful compile. I'll go back and grab some old revisions of code to try them again. In the meantime, any suggestions?
----------------------------------------------------

I did a web search and a usenet archive search on that line,
and there's not very much information available.

Apparently, it's related to Delphi, which is probably what
the PCW IDE is written in.

Some articles in usenet say that it shows up on slow systems.
So that makes me wonder if you're running on a network drive ?
That might slow it down, and cause the problem.
___________________________
This message was ported from CCS's old forum
Original Post ID: 12942
rabarton
Guest







Re: Mystery PCW error when compiling
PostPosted: Fri Mar 21, 2003 10:46 pm     Reply with quote

:=
:=I did a web search and a usenet archive search on that line,
:=and there's not very much information available.
:=
:=Apparently, it's related to Delphi, which is probably what
:=the PCW IDE is written in.
:=
:=Some articles in usenet say that it shows up on slow systems.
:=So that makes me wonder if you're running on a network drive ?
:=That might slow it down, and cause the problem.

I'm running on a standalone PC that is over 1 GHz. Don't know what speed exactly, but from the sound of it it's fast enough to not be the problem.

I did try save, close, open and try to compile again and that didn't solve anything. I found the problem right before leaving work so I didn't get a chance to reboot my entire machine and try again. I had been running the program for several days w/out a reboot, so maybe a memory leak or some other problem has caused this to come up. I'll try again Mondayc morning. Until then if you see/find anything else please send it my way.

Thanks for the effort!
___________________________
This message was ported from CCS's old forum
Original Post ID: 12946
rabarton
Guest







Found the problem
PostPosted: Mon Mar 24, 2003 7:57 am     Reply with quote

:=
:=I'm running on a standalone PC that is over 1 GHz. Don't know what speed exactly, but from the sound of it it's fast enough to not be the problem.
:=
:=I did try save, close, open and try to compile again and that didn't solve anything. I found the problem right before leaving work so I didn't get a chance to reboot my entire machine and try again. I had been running the program for several days w/out a reboot, so maybe a memory leak or some other problem has caused this to come up. I'll try again Mondayc morning. Until then if you see/find anything else please send it my way.
:=
:=Thanks for the effort!

Tried a reboot, no good... I was in the process of trying new projects with the same code, etc. and found a .err file in the project directory. Its contents:
Error[112] c:\...\include.c 1043 : Function used but not defined: rb_isr
I had used an #IFDEF block to selectively include this function, but reversed the logic. I needed an #IFNDEF there. I fixed this and now everything works as planned.
Don't know why this didn't come up in the compiler window, but at least I found it!
___________________________
This message was ported from CCS's old forum
Original Post ID: 12996
Display posts from previous:   
Post new topic   Reply to topic    CCS Forum Index -> General CCS C Discussion All times are GMT - 6 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group