CCS C Software and Maintenance Offers
FAQFAQ   FAQForum Help   FAQOfficial CCS Support   SearchSearch  RegisterRegister 

ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

CCS does not monitor this forum on a regular basis.

Please do not post bug Reports on this forum. Send them to support@ccsinfo.com

MPLAB 7.5

 
Post new topic   Reply to topic    CCS Forum Index -> General CCS C Discussion
View previous topic :: View next topic  
Author Message
Datman
Guest







MPLAB 7.5
PostPosted: Wed Jun 20, 2007 4:56 pm     Reply with quote

are there any known issues using PCM with MPLAB 7.50? I purchased the PCM compiler this morning, have been successfully trying test code and programming a 16F877A. However MPLAB constantly crashes, and whenever i try to open the old project it says that the project is now corrupt... so after every crash I have to create a new project and re-add my source files ( which are still ok )... any ideas...? happens at random every half hour or so
PCM programmer



Joined: 06 Sep 2003
Posts: 18031

View user's profile Send private message

PostPosted: Wed Jun 20, 2007 5:08 pm     Reply with quote

Here are some threads on the Microchip forum about it:
http://forum.microchip.com/tm.aspx?m=201367&mpage=2
http://forum.microchip.com/tm.aspx?m=260347

Download page for older versions of MPLAB:
http://www.microchip.com/stellent/idcplg?IdcService=SS_GET_PAGE&nodeId=1406&dDocName=en023073

On this page, one person claims he "rolled back to 7.41" and
it's stable with CCS.
http://forum.microchip.com/tm.aspx?m=201367&mpage=2

Here's a link to MPLAB v7.41. (This is a 37 MB download)
http://ww1.microchip.com/downloads/en/DeviceDoc/MP741.zip
kevcon



Joined: 21 Feb 2007
Posts: 142
Location: Michigan, USA

View user's profile Send private message

PostPosted: Thu Jun 21, 2007 7:05 am     Reply with quote

7.61 is a bit more stable, it mainly crashes when I'm programming a chip.

The one thing I really like about 7.61 is dockable windows; which allows you to use multiple monitors
YUM



Joined: 27 May 2004
Posts: 12
Location: Austria

View user's profile Send private message Send e-mail

MPLAB crash
PostPosted: Wed Jul 11, 2007 5:37 am     Reply with quote

Hi,

I used MPLAB 7.50, 7.61a in conjunction with CCS 3.227 on Windows XP.
It crashed every few minutes, always when i pressed the programming tab or the compiling tab.

Of course i have read nearly everything on the internet and tried a lot.

Finally it only helped to:
-) uninstall ALL, manually cleaned the registry (cleaned everything with "MPLAB", "Microchip", "CCS")
-) reinstall MPLAB 7.20 (!!!) - restart windows
-) reinstall CCS 3.227 - restart windows
-) reinstall MPLAB plugin - the old one (!!!) which has 299.304 bytes
now i work on my project for some days, w/o a single crash.
I have to mention that i also gave more virtual memory.

I hope doing the same way can help you, too. Cool
Humberto



Joined: 08 Sep 2003
Posts: 1180
Location: Buenos Aires la Reina del Plata

View user's profile Send private message

My too !!!
PostPosted: Thu Jul 19, 2007 12:51 pm     Reply with quote

Well, after some "cleanning" in my Vaio, I reinstalled all my tools and programs.
The point is that I didn´t keep the "old" MPLAB/CCS plugin wich I used to use,
instead I installed the last and fresh Twisted Evil MPLAB plugin version wich is the only
available in the site.
After that I realized that I´m in the same problem, the suit MPLAB/ICD2 that
I use to debug, start crashing. Shocked I´m using CCS V3.236.

Quote:

-) reinstall MPLAB plugin - the old one (!!!) which has 299.304 bytes

I search in Microchip/MPLAB site but they do not keep old plugins versions too.
Pls, somebody can point me where/how can I get the old one ?


Many thanks in advance,


Humberto
treitmey



Joined: 23 Jan 2004
Posts: 1094
Location: Appleton,WI USA

View user's profile Send private message

PostPosted: Thu Jul 19, 2007 2:58 pm     Reply with quote

see your private messages.
Humberto



Joined: 08 Sep 2003
Posts: 1180
Location: Buenos Aires la Reina del Plata

View user's profile Send private message

PostPosted: Thu Jul 19, 2007 3:04 pm     Reply with quote

Hi treitmey,

Many thanks !!! Very Happy

Now I learned the lesson... (one more!!!) Cool

In my next life -if so- for sure, I will be a carpenter !!!


Humberto
Bill Boucher



Joined: 04 Feb 2005
Posts: 34
Location: Chatham,ON,CA

View user's profile Send private message Send e-mail Visit poster's website

PostPosted: Thu Jul 19, 2007 5:46 pm     Reply with quote

treitmey wrote:
see your private messages.


I wouldn't mind seeing that private message myself. I'm in the same boat along with several others both at home and at the automotive company where I work. We are all using CCS under MPLAB under XP and they all crash randomly and often, regardless of PC manufacturer.
treitmey



Joined: 23 Jan 2004
Posts: 1094
Location: Appleton,WI USA

View user's profile Send private message

PostPosted: Fri Jul 20, 2007 7:47 am     Reply with quote

sure,
I just wasn't too keen on my personal web page given
its not that professional. I'm learning c# so I don't have much free time

CCS mplab_plugin sized 299.304 bytes
http://xxx.googlepages.com ...(edited)(link removed)

I hope this fixes the problem. Report back
DMX_MODBUS
Guest







Version 7.6+ issues
PostPosted: Thu Jul 26, 2007 10:10 am     Reply with quote

I was having massive lockup issues with 7.6+. As suggested, I uninstalled
7.6, went through the registry and removed any (obvious) leftover MPLAB
entries (and there were plenty). There were some entries that I wasn't sure
about... i.e. CCS references to MPLAB, so I left anything that wasn't
obviously installed by microchip. I then removed/uninstalled the CCS compiler as a JUST-IN-CASE. Reinstalled 7.41, reinstalled CCS (latest
version). Ran the OLD CCS mplab utility. Everything is now stable and
have not had a lockup yet. The only extra thing I had to do was manually
change where MPLAB looked for compiler. It defaulted to pointing to the
included basic CCS compiler, and it had to be directed to the PICC
folder. CCS tech support helped out on that one.

The nice gentleman at Microchip that tried
to help me with the "trouble ticket" seemed "baffled". It wasn't until I put
forth a little more effort to track down the problem myself and search google that I found the boards here as well as microchip... and a few other places as well. With so many postings HERE as well
as on the microchip message boards in relation to lock up issues with 7.5
and greater, I was disappointed how clueless they were about the situation.

Perhaps 7.7... 7.71...??

-working
Display posts from previous:   
Post new topic   Reply to topic    CCS Forum Index -> General CCS C Discussion All times are GMT - 6 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group