CCS C Software and Maintenance Offers
FAQFAQ   FAQForum Help   FAQOfficial CCS Support   SearchSearch  RegisterRegister 

ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

CCS does not monitor this forum on a regular basis.

Please do not post bug Reports on this forum. Send them to support@ccsinfo.com

Single Stepping through fprint - goes int run mode

 
Post new topic   Reply to topic    CCS Forum Index -> CCS ICD / Mach X / Load-n-Go
View previous topic :: View next topic  
Author Message
Kermit
Guest







Single Stepping through fprint - goes int run mode
PostPosted: Sun Mar 27, 2005 9:19 pm     Reply with quote

When I single step through a fprintf statement the debugger goes into run mode. I'm using the hardware SPI. What is the debugger up to??? Is there a simple workarourd without setting a breakpoint after every fprintf?
smashHIT



Joined: 28 Nov 2004
Posts: 14

View user's profile Send private message ICQ Number

PostPosted: Fri May 06, 2005 10:02 am     Reply with quote

I to have the same problem.
I wish that someone smart could find a solution to that...

Rolling Eyes
Horkesley Elec
Guest







printf
PostPosted: Tue Jun 07, 2005 5:37 am     Reply with quote

Hi,

Go into assembly and single step. you will see that the code is looping one instruction.

Regards,
Display posts from previous:   
Post new topic   Reply to topic    CCS Forum Index -> CCS ICD / Mach X / Load-n-Go All times are GMT - 6 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group