CCS C Software and Maintenance Offers
FAQFAQ   FAQForum Help   FAQOfficial CCS Support   SearchSearch  RegisterRegister 

ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

CCS does not monitor this forum on a regular basis.

Please do not post bug Reports on this forum. Send them to support@ccsinfo.com

Problems using the ICD-40U and PIC18f6520

 
Post new topic   Reply to topic    CCS Forum Index -> CCS ICD / Mach X / Load-n-Go
View previous topic :: View next topic  
Author Message
jds162



Joined: 07 Jul 2004
Posts: 2

View user's profile Send private message

Problems using the ICD-40U and PIC18f6520
PostPosted: Wed Jul 07, 2004 10:29 am     Reply with quote

I recently purchased a ICD-40U to be used to program a PIC18f6520. I followed the directions and hooked the ICD up to the PIC as layed out in the help files that came with the ICD. I also supplied power to all the Vdd pins and grounded all the Vss pins as described in the manual for the PIC. We also hooked up a clock to the two pins on the chip but it was only running at about 200kHz. However, I am still unable to get the ICD to recognize that the chip is connected. I was wondering if any one had any suggests or help because we need to be able to program the chip.
dyeatman



Joined: 06 Sep 2003
Posts: 1780
Location: Norman, OK

View user's profile Send private message

ICD-U
PostPosted: Wed Jul 07, 2004 5:13 pm     Reply with quote

How is the ICD-U connected?
What message are you getting from the ICD-U software?
Can you run ICD-U test? Does it pass or fail?
What is the green LED on the ICD-U doing after powerup and when you try to connect?
Guest








PostPosted: Wed Jul 07, 2004 10:09 pm     Reply with quote

The ICD-U is connected using the supplied telephone cable to a jack on the prototyping board with the leads from the jack running directly to the pins on the PIC (as specified by the help manually with the ICD software). The message is that the target cannot be found. The ICD-U passes the test everytime with a solid green light. My computer has no problem seeing the ICD but the ICD just will not recognize the target chip.
jds162



Joined: 07 Jul 2004
Posts: 2

View user's profile Send private message

PostPosted: Wed Jul 07, 2004 10:10 pm     Reply with quote

Sorry, forgot to sign in.
Display posts from previous:   
Post new topic   Reply to topic    CCS Forum Index -> CCS ICD / Mach X / Load-n-Go All times are GMT - 6 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group