CCS C Software and Maintenance Offers
FAQFAQ   FAQForum Help   FAQOfficial CCS Support   SearchSearch  RegisterRegister 

ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

CCS does not monitor this forum on a regular basis.

Please do not post bug Reports on this forum. Send them to support@ccsinfo.com

ICD-U40 doesn't work

 
Post new topic   Reply to topic    CCS Forum Index -> CCS ICD / Mach X / Load-n-Go
View previous topic :: View next topic  
Author Message
Lorenzo



Joined: 23 Apr 2004
Posts: 14
Location: Pescara (Italy)

View user's profile Send private message

ICD-U40 doesn't work
PostPosted: Mon Jun 21, 2004 12:53 am     Reply with quote

I have to program a 16LF648A with 3V power supply but
ICD-U40 rarely works.
With a supply voltage higher it works well.
Please help
Lorenzo
MGP



Joined: 11 Sep 2003
Posts: 57

View user's profile Send private message

PostPosted: Wed Jun 23, 2004 4:28 pm     Reply with quote

You might check the spec sheet for the 16LF648A, but I think the chip needs ~4.5V to do a bulk erase. Since the ICD needs to do a bulk erase to load your program into the chip, it could be the problem. I know a lot of people have missed this in the specification for most of the 18F chips and it can bite you on a 3V design when you need to program the chip in-circuit.
Display posts from previous:   
Post new topic   Reply to topic    CCS Forum Index -> CCS ICD / Mach X / Load-n-Go All times are GMT - 6 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group