CCS C Software and Maintenance Offers
FAQFAQ   FAQForum Help   FAQOfficial CCS Support   SearchSearch  RegisterRegister 

ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

CCS does not monitor this forum on a regular basis.

Please do not post bug Reports on this forum. Send them to support@ccsinfo.com

ICD-U - Test Target error

 
Post new topic   Reply to topic    CCS Forum Index -> CCS ICD / Mach X / Load-n-Go
View previous topic :: View next topic  
Author Message
ksplem
Guest







ICD-U - Test Target error
PostPosted: Sat May 29, 2004 4:39 am     Reply with quote

Hi,

I just hooked up a CCS software proto-board, my new ICD-U40 and a PIC18F448 into the board. I don't think it matters but the PIC18F448 is from Digikey since the kit didn't come with one even though I asked.

I wrote a quick & simple test program and then tried to compile, download and then run it. It compiles...

The 'ICD Control Program' doesn't seem to download and so I hit 'Test Target' and here is the message box.

---------------------------
ICD Error
---------------------------
Unknown PIC18 device, ID: 0101 if this is a valid id, then make sure the algorithm inside chipedit is set correctly.
---------------------------
OK
---------------------------

I have green lights on for board power and ICD-U40.

How do I get around this or download the algorithm?

Thanks for any help!
ksplem
Guest







Re: ICD-U - Test Target error
PostPosted: Sat May 29, 2004 5:01 am     Reply with quote

It just started working, perhaps I'm a dope! Shocked

I resinstalled MPLAB and then hit proto-board reset and then the chip was detected and I seem to be running. Sorry for the post litter!

ksplem wrote:
Hi,

I just hooked up a CCS software proto-board, my new ICD-U40 and a PIC18F448 into the board. I don't think it matters but the PIC18F448 is from Digikey since the kit didn't come with one even though I asked.

I wrote a quick & simple test program and then tried to compile, download and then run it. It compiles...

The 'ICD Control Program' doesn't seem to download and so I hit 'Test Target' and here is the message box.

---------------------------
ICD Error
---------------------------
Unknown PIC18 device, ID: 0101 if this is a valid id, then make sure the algorithm inside chipedit is set correctly.
---------------------------
OK
---------------------------

I have green lights on for board power and ICD-U40.

How do I get around this or download the algorithm?

Thanks for any help!
Display posts from previous:   
Post new topic   Reply to topic    CCS Forum Index -> CCS ICD / Mach X / Load-n-Go All times are GMT - 6 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group