CCS C Software and Maintenance Offers
FAQFAQ   FAQForum Help   FAQOfficial CCS Support   SearchSearch  RegisterRegister 

ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

CCS does not monitor this forum on a regular basis.

Please do not post bug Reports on this forum. Send them to support@ccsinfo.com

ICD-U40 won't release my uP

 
Post new topic   Reply to topic    CCS Forum Index -> CCS ICD / Mach X / Load-n-Go
View previous topic :: View next topic  
Author Message
htdata
Guest







ICD-U40 won't release my uP
PostPosted: Tue May 11, 2004 3:16 am     Reply with quote

Hi all,

I am using an ICD-U40 with PCWH 3.190.

Everything works fine with the ICD connected to my PCB, but it does not whe it is removed. I am trying to develop two uP that communicate with each other, so I need to be able to remove the ICD from one circuit and connect it to the other.

I have removed the

Code:

#device ICD=TRUE


statement but this does not seem to do the trick. Does anyone have any suggestions.

Thanks,

Jason.
Haplo



Joined: 06 Sep 2003
Posts: 659
Location: Sydney, Australia

View user's profile Send private message

PostPosted: Tue May 11, 2004 3:31 am     Reply with quote

Describe the circuit connected to the MCLR pin.
htdata
Guest







PostPosted: Tue May 11, 2004 4:14 am     Reply with quote

Thanks for the advice. I checked the circuit and somehow had connected the 10K resistor to MCLR at one end and Gnd at the other. Once it was connected to where it was supposed to be all works fine.

Once again many thanks for asking the obvious question; I should have asked it to myself first.

Jason.
Haplo



Joined: 06 Sep 2003
Posts: 659
Location: Sydney, Australia

View user's profile Send private message

PostPosted: Tue May 11, 2004 4:28 am     Reply with quote

Sometimes the obvious things are the most difficult to find. Glad it is working now.
prwatCCS



Joined: 10 Dec 2003
Posts: 67
Location: West Sussex, UK

View user's profile Send private message

PostPosted: Tue May 11, 2004 4:37 am     Reply with quote

Good to hear that the problem is solved.

For future reference, please place problems like this one in the NEW
Hardware Forum :cool:

It's feeling rather lonely at present.
_________________
Peter Willis
Development Director
Howard Eaton Lighting Ltd UK
Display posts from previous:   
Post new topic   Reply to topic    CCS Forum Index -> CCS ICD / Mach X / Load-n-Go All times are GMT - 6 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group