CCS C Software and Maintenance Offers
FAQFAQ   FAQForum Help   FAQOfficial CCS Support   SearchSearch  RegisterRegister 

ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

CCS does not monitor this forum on a regular basis.

Please do not post bug Reports on this forum. Send them to

Mach X failed - "Unknown Device" in Windows

Post new topic   Reply to topic    CCS Forum Index -> CCS ICD / Mach X / Load-n-Go
View previous topic :: View next topic  
Author Message

Mach X failed - "Unknown Device" in Windows
PostPosted: Mon Jan 11, 2010 12:35 am     Reply with quote

Quick overview: Mach X is showing up as Unknown Device in Windows after a typical firmware burn failed. Is the unit dead and I need to send it in for repairs or can I do something quick and easy to recover it?

Details: I fear I’ve bricked my Mach X. Until this incident, all has been working fine. I was burning an 12F683 like I’ve done a bazzilion times before but this time the firmware burn failed. Trying again, I got an error from the CCS Load tool stating that it couldn’t find the Mach X. I unplugged the unit from the USB slot and reconnected it. Windows reported that the newly-found device was an Unknown Device instead of the familiar Mach X designation. After a couple of typical debug steps (delete and reinstall the driver, change cables, etc) I went through the install process on a different PC. It gave the same Unknown Device error when connecting via USB. Yikes.

Question: Have I bricked the Mach X requiring me to send it back to CCS? Is there something I’ve missed I should try?

My Setup:
Mach X
CCS Device Programmer version 4.022
Connected via USB
Windows XP Pro SP 3

Thank you for any suggestions.
Chris Weaver

Joined: 28 Mar 2009
Posts: 17

View user's profile Send private message Send e-mail

machx harware problem
PostPosted: Fri May 07, 2010 4:00 am     Reply with quote

Hi ,

I buy an Mach x programmer(Rev 5.0) and when try to install and connect to my
computer,get several error like this,
driver install compelet but when connect programmer to computer USB port I get an error message "Unknown USB device".
I try to fix this error by work on driver installing but nothing change and
harware error still remain.
finaly I think USB converter IC (FT232Bl)maybe damage and replace it with one new chipset ,but this error remain.
At last I replace FT232 Ic from mach X PCB and draw FT232 IC connection
in Circuit and compare with FT232 datasheet.
This is amazing,I find some wrong connection and some wrong component
assignment in Mach X PCB and try to fix this problems.
After fixing this problems and update Mach X firmware ,my programmer
work fine without any problem.I test it in ZIF programing ,In circuit programing and in debug mode,and it work very fine.
Detail of modification is:
1-FT232 chipset configure in "USB Bus Powered" mode and in this mode
pin 14(POWERCTL) must connect to GND Not VCC.In my hardware PCB
it connect to VCC.
2-pin 30(AVCC) must connect to GND via an 0.1Uf capacitor but in My PCB
it connect to pin 3(VCC).
3-Pin 6(3v3OUT)must connect to GND via an 33nf capacitor but in my
hardware it connect to pin 7(USB DP) via 1.5K resistor.I fix this by cutting
PCB path.
4-pin 5(RSTOUT#)must connect to to pin 7(USB DP) via 1.5K resistor but
in my hardware PCB it No connect.

after fix this connection and modification my programmer work fine.
you can find this correction in attached image.

best regards,
Mohammad kouchekzadeh.

Joined: 08 Jul 2007
Posts: 15
Location: Cordoba - Argentina

View user's profile Send private message Visit poster's website ICQ Number

What about MachX in Windows 7
PostPosted: Mon Jul 26, 2010 11:48 am     Reply with quote

Hello, I first wrote to CCS directly but one week later I don't have answer. I'm desperate. I can't make MachX work under Windows 7 x64 64 bits. The first time I run usb drivers the system attempts to recognize it, but after first restart of the system It never ever recognize it again. I've tried to uninstall the driver and install it again but nothing happend. Please help me beceause I really need this get to work and I can't get support from CCS. Thanks.
Display posts from previous:   
Post new topic   Reply to topic    CCS Forum Index -> CCS ICD / Mach X / Load-n-Go All times are GMT - 6 Hours
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2005 phpBB Group